viernes, 30 de diciembre de 2011

Función INDICE. Forma de referencia

En la entrada anterior hemos utilizado la función INDICE en la "forma matricial". Esta función tiene una segundo modo de utilización: la "forma de referencia".

Las inversiones realizadas por una empresa entre los años 2007 y 2011 en sus sucursales de Europa, América y Asia han sido clasificadas por departamentos. Eligiendo un continente, un año y un departamento, debemos obtener la cifra invertida con una fórmula.

El ejercicio se resuelve facilmente usando la función INDICE en su forma de referencia, cuya sintaxis es:

INDICE(referencias;núm_fila;[núm_columna];[núm_área])

  • referencias son los distintos rangos en los que hay que realizar la búsqueda. Si son más de uno, se escriben separados por punto y coma y, todo ello, encerrado entre paréntesis.
  • núm_fila es la fila en la que hay que buscar.
  • núm_columna es la columna en la que hay que buscar.
  • núm_área es el rango (el área) en el que hay que realizar la búsqueda. La primera área es la 1; la segunda, la 2; la tercera, la 3, etc.

En J2 elegimos un continente; por ejemplo, Asia

En J3 elegimos el departamento: Marketing

En J4, el año: 2010

En J6:
=INDICE((B3:G9;B12:G18;B21:G27);COINCIDIR($J$3;$B$3:$B$9;0);COINCIDIR($J$4;$B$3:$G$3;0);COINCIDIR($J$2;{"Europa";"América";"Asia"};0))

  • (B3:G9;B12:G18;B21:G27), primer argumento, especifica las tres tablas en un orden concreto: Europa (que es el área 1), América (área 2) y Asia (área 3).
  • COINCIDIR($J$3;$B$3:$B$9;0) devuelve el número de la fila (de cualquiera de las tablas) donde se encuentra el departamento buscado.
  • COINCIDIR($J$4;$B$3:$G$3;0) devuelve el número de la columna (de cualquiera de las tablas) donde se encuentra el año buscado.
  • COINCIDIR($J$2;{"Europa";"América";"Asia"};0) devuelve un número del 1 al 3. En el ejemplo, como J2 contiene Asia, devuelve 3. Éste es el área donde se realizará la búsqueda.

 


No hay comentarios:

Publicar un comentario