miércoles, 18 de enero de 2012

Búsqueda en una tabla

El resultado de la búsqueda de un dato en una tabla puede ser un número (las veces que el dato está repetido) o, simplemente, VERDADERO o FALSO (está o no está; independientemente del número de veces que pueda estar repetido). Consideremos una tabla de actividades deportivas que se desarrollan en distintas fechas:

Hay deportistas que participan en varias modalidades en diferentes fechas. Algunos nombres están escritos en minúscula. Poniendo un nombre en D10, vamos a realizar cuatro tipos de búsquedas.
  1. Comprobar el número de veces que aparece el nombre en la tabla. No se tendrán en cuenta las mayúsculas ni las minúsculas.
  2. Comprobar el número de veces que aparece el nombre en la tabla, teniendo en cuenta las mayúsculas y las minúsculas.
  3. Comprobar si el nombre existe. No se tendrán en cuenta las mayúsculas ni las minúsculas.
  4. Comprobar si el nombre existe, teniendo en cuenta las mayúsculas y las minúsculas.
En D10 ponemos un nombre cualquiera: carlos

En D11:
=SUMAPRODUCTO(--((C3:F8)=D10))    [Resultado: 1]

En E11 pondremos otra solución, utilizando SUMA en vez de SUMAPRODUCTO.

En E11:
=SUMA(--((C3:F8)=D10))    [Terminar con Ctrl + Mayús. + Intro. Resultado: 1]

En D12:
=SUMAPRODUCTO(--(IGUAL(C3:F8;D10)))    [Resultado: 0]

Ahora, con SUMA:

En E12:
=SUMA(--(IGUAL(C3:F8;D10)))    [Terminar con Ctrl + Mayús. + Intro. Resultado: 0] 

-------------------------------------------------------------------------------------------------------------------------
La función IGUAL distingue entre mayúsculas y minúsculas. Así:

="A"="a"     [Devuelve: VERDADERO]

=IGUAL("A";"a")      [Devuelve: FALSO]
-------------------------------------------------------------------------------------------------------------------------

En D13:
=O(C3:F8=D10)    [Terminar con Ctrl + Mayús. + Intro. Resultado: VERDADERO]

En D14:
=O(IGUAL(C3:F8;D10))     [Terminar con Ctrl + Mayús. + Intro. Resultado: FALSO]



 
 
 

No hay comentarios:

Publicar un comentario