viernes, 4 de mayo de 2012

Referencia a rangos de otros libros

En la hoja Población del libro S338-Poblacion.xlsx, tenemos una tabla con las poblaciones de todas las provincias españolas.

En la hoja Extensión del libro S338-Extension.xlsx, tenemos la tabla de provincias en la que faltan los datos de la columna Población. Estos datos los obtendremos del libro anterior.

Pueden darse varias posibilidades:
  1. Que ambos libros estén abiertos en nuestro ordenador.
  2. Que el libro del que queremos extraer los datos no esté abierto pero que se encuentre en una carpeta de nuestro propio ordenador.
  3. Que el libro del que queremos extraer los datos no esté abierto y se encuentre en una carpeta de otro ordenador de nuestra Intranet.
  4. Que conozcamos la dirección de Internet donde está guardado el libro.
Veamos la forma de obtener la información en cada caso.

Caso 1º: Los dos libros abiertos

Abrimos el primer libro y accedemos a Archivo para abrir el segundo libro. Es importante que ambos libros se abran desde la misma ventana de Excel.

En la celda E6 de la hoja Extensión escribimos:
=BUSCARV(C6;'[S338-Poblacion.xlsx]Población'!$C$6:$D$57;2;FALSO)

Extendemos la fórmula hasta la fila 57.

En E58:
=SUMA(E6:E57)     [Resultado: 46.744.116]

Guardamos ambos libros y salimos de Excel.

Cuando abramos otra vez el libro S338-Extension.xlsx, Excel nos mostrará un cuadro de diálogo indicándonos que los datos se han obtenido de una fuente externa. Puesto que esta fuente ha podido ser modificada, nos ofrece la posibilidad de actualizar los datos con los cambios habidos.

Elegimos la opción que nos interese y comprobamos que la fórmula de la celda E6 se ha modificado; el nombre del libro [S338-Poblacion.xlsx], ahora, irá precedido de la ruta donde se ha guardado. Por ejemplo, yo lo he guardado en el escritorio y la fórmula que muestra mi ordenador es la siguiente:
=BUSCARV(C6;'C:\Users\Javi\Desktop\[S338-Poblacion.xlsx]Población'!$C$6:$D$57;2;FALSO)

Caso 2º: Un libro abierto y el otro en una carpeta de nuestro ordenador

Visto el caso anterior, éste es evidente; bastará poner la fórmula modificada en E6:
=BUSCARV(C6;'C:\Users\Javi\Desktop\[S338-Poblacion.xlsx]Población'!$C$6:$D$57;2;FALSO)

Caso 3º: Un libro abierto y el otro en una carpeta de la Intranet

Este caso es similar al anterior. Sólo necesitamos conocer la ruta en el servidor:
=BUSCARV(C6;'\\Servidor\Carpeta\[S338-Poblacion.xlsx]Población'!$C$6:$D$57;2;FALSO)

Caso 4º: Un libro abierto y el otro alojado en Internet

Una vez conocida la URL del alojamiento, pondremos una fórmula siguiendo este esquema:
=BUSCARV(C6;'http://www.servidor.com/Carpeta/[S338-Poblacion.xlsx]Población'!$C$6:$D$57;2;FALSO)

Si el fichero S338-Poblacion.xlsx estuviera alojado en:

la fórmula de E6 debería ser:
=BUSCARV(C6;'http://www.fileden.com/files/2011/10/14/3209175/[S338-Poblacion.xlsx]Población'!$C$6:$D$57;2;FALSO)


 
 
 
 

No hay comentarios:

Publicar un comentario