viernes, 24 de agosto de 2012

Dígitos de control de una cuenta bancaria

Hace unos días recibí una llamada telefónica, supuestamente, de mi compañía telefónica. La empleada me ofrecía el cambio de router y una serie de mejoras gratuitas. Al final de una larga y convincente explicación, me aseguró que para llevar a cabo la operación era imprescindible que le diera el número de mi cuenta corriente, pero, por motivos de seguridad, no debía proporcionarle los dos dígitos de control. Naturalmente, me despedí cortésmente y colgué.

Este intento de... ¿cómo llamarlo? me ha proporcionado el tema del artículo de hoy: los Dígitos de Control de las cuentas bancarias.

Todas las cuentas bancarias tienen un número de identificación. Este número, llamado Código Cuenta Cliente (CCC), está compuesto por veinte dígitos que corresponden a:
  • Código de la Entidad (los 4 primeros dígitos) donde radica la cuenta. Lo proporciona el Banco de España.
  • Código de la Oficina (los 4 dígitos siguientes) que identifica la oficina donde el cliente tiene abierta la cuenta.
  • Dígitos de Control (2 dígitos: el noveno y el décimo). El primero sirve para verificar los Códigos de Entidad y Oficina; el segundo para verificar el Número de Cuenta.
  • Número de Cuenta (los 10 últimos dígitos) que incluye todos los identificadores de índole interna que la Entidad desee utilizar para individualizar cada cuenta.
La determinación de los dos Dígitos de Control se realiza de acuerdo a las especificaciones de la Norma bancaria 34 de la AEB (Asociación Española de Banca). Para el cálculo de los dígitos hay que realizar una serie de operaciones, que se mostrarán en el ejemplo que sigue, basándose en la siguiente tabla ponderada:

Consideremos el caso hipotético de un cliente que ha abierto una cuenta bancaria en la Entidad 0210 y en la Oficina 0345. La entidad le asigna el Número de Cuenta 0000067892 y dos Dígitos de control que vamos a determinar.
 
El CCC de la cuenta será 0210 0345 xz 0000067892. Debemos calcular los valores de los dos Dígitos de control representados por xz.
  • El dígito x se obtiene a partir de los 8 dígitos de la Entidad y la Oficina (02102345) multiplicándolos ordenadamente por los 8 primeros valores de la tabla y sumando los resultados.
     
  • A continuación, se obtiene el resto de la división entre la suma (84) y 11. El resultado es 7.
  • El siguiente paso consiste en restar 11 menos el resto anterior: 11-7=4
  • El número obtenido es el primer valor (x) de los Dígitos de Control, salvo que la resta anterior sea 10 u 11. Si es 10, x toma el valor 1; si es 11, toma el valor 0. En nuestro caso, no se da ninguna de estas excepciones, por lo que x valdrá 4.
Ya hemos determinado el valor del primer dígito. Vamos a por el segundo.
  • El dígito z se obtiene a partir de los 10 dígitos del Número de Cuenta (0000067892) multiplicándolos ordenadamente por los 10 valores de la tabla y sumando los resultados.
 
  • Volvemos a repetir el mismo proceso que en el caso anterior. Hallamos el resto de la división entre la suma (218) y 11. El resultado es 9.
  • Restamos 11 menos el resto: 11-9=2
  • Si el valor obtenido es 10, z valdrá 1; si es 11, 0; si es cualquier otro número, z será ese número. Por tanto, en el ejemplo que estamos manejando, z es 2.
En conclusión, los Dígitos de Control son x=4 y z=2 y el Código Cuenta Cliente (CCC) es 0210 0345 42 0000067892.
 
Una vez conocida la mecánica del cálculo de los Dígitos de Control, vamos a hacer un ejercicio en el que dado un Código Cuenta Cliente (CCC) determinemos si es un código correcto o incorrecto. Para ello, calcularemos los Dígitos de Control y los compararemos con los del CCC.
 
El Código Cuenta Cliente lo escribiremos en la celda C5, los cálculos los haremos en las columnas F:M y el resultado lo pondremos en C7.
 
El primer paso consiste en asignar formato de texto a la celda C5. Si no lo hacemos, Excel le asignará el formato general y el número quedará expresado en modo exponencial (2,10035E+18). Para hacerlo, en el menú contextual, accedemos a Formato de celdas y, en la pestaña Número, elegimos la categoría Texto.
 
En C5 escribimos los 20 dígitos de la cuenta: 02100345420000067892
 
Para obtener el primer Dígito de Control, extraemos en F3 los 8 primeros números de la cuenta y, debajo, ponemos cada dígito en una fila distinta.
 
En F3:
=IZQUIERDA(C5;8)    [Resultado: 02100345]
 
En F4:
=EXTRAE($F$3;9-FILA(A1);1)    [Resultado: 5]
 
Extendemos la fórmula de la celda F4 hasta la fila 11.
 
En la columna G obtendremos el producto de cada dígito con los valores correspondientes de la tabla ponderada. Esta tabla la tenemos en el rango L3:M13.
 
En G4:
=F4*M4    [Resultado: 30]
 
Extendemos la fórmula de la celda G4 hasta la fila 11.
 
Sumamos los números de la columna G, dividimos la suma por 11 para quedarnos con el resto y hallamos la diferencia entre 11 y este valor. Finalmente, comprobamos si el resultado es distinto de 10 u 11 y obramos en consecuencia. Todo esto lo hacemos en G15:G18.
 
En G15:
=SUMA(G4:G11)    [Resultado: 84]
 
En G16:
=RESIDUO(G15;11)    [Resultado: 7]
 
En G17:
=11-G16    [Resultado: 4]
 
En G18:
=SI(Y(G17<>10;G17<>11);G17;SI(G17=10;1;0))    [Resultado: 4]
 
Ya hemos descubierto que el primer Dígito de Control es el 4. El segundo dígito se obtiene de forma similar. Primero, extraeremos los 10 últimos números de la cuenta y los pondremos en filas diferentes.
 
En I3:
=DERECHA(C5;10)
 
En I4:
=EXTRAE($I$3;11-FILA(A1);1)    [Resultado: 2]
 
Extendemos la fórmula de la celda I4 hasta la fila 13.
 
En J4:
=I4*M4    [Resultado: 12]
 
Extendemos la fórmula de la celda J4 hasta la fila 13.
 
En J15:
=SUMA(J4:J13)    [Resultado: 218]
 
En J16:
=RESIDUO(J15;11)    [Resultado: 9]
 
En J17:
=11-J16    [Resultado: 2]
 
En J18:
=SI(Y(J17<>10;J17<>11);J17;SI(J17=10;1;0))    [Resultado: 2]
 
El segundo Dígito de Control es el 2.
 
Sólo nos falta comprobar si los dígitos noveno y décimo del CCC que nos han proporcionado forman 42. Si coincide, la cuenta será correcta; en caso contrario, será incorrecta.
 
En C7:
=SI(ESBLANCO(C5);"";SI(G18&J18=EXTRAE(C5;9;2);"Correcto";"Incorrecto"))    [Resultado: Correcto]
 
Cuando os pidan el número de vuestra cuenta bancaria y os digan que, por motivos de seguridad, no les proporcionéis los dígitos de control... ¡cuidado! Hay trampa. Como acabamos de comprobar en este ejercicio, los números ocultos se pueden obtener fácilmente.
 
 
 
 

No hay comentarios:

Publicar un comentario