martes, 30 de octubre de 2012

Cuatro formas de calcular la media ponderada

En el rango B2:C15 hemos registrado un número de personas agrupadas por edades. Queremos saber cuál es la edad media de este colectivo.

Primer método: Con celdas auxiliares
 
Usaremos la columna G para obtener resultados intermedios.
 
En G3:
=B3*C3    [Resultado: 1.127]
 
Extendemos la fórmula hasta la fila 15.
 
En E3:
=SUMA(G3:G15)/SUMA(B3:B15)    [Resultado 38,26]
 
Segundo método: Con una fórmula matricial
 
Podemos prescindir de la columna auxiliar almacenando los valores en una matriz. Luego, sumamos todos los valores de la matriz y dividimos el resultado por el número total de personas de la muestra. Todo en un solo paso.
 
En E3:
=SUMA(B3:B15*C3:C15)/SUMA(B3:B15)    [Terminamos con Ctrl + Mayúscula + Intro]
 
Tercer método: Con la función SUMAPRODUCTO para evitar la fórmula matricial
 
Ya hemos visto en otros ejercicios cómo la función SUMAPRODUCTO permite transformar una fórmula matricial en una normal. Bastará sustituir la primera SUMA por SUMAPRODUCTO.
 
En E3:
=SUMAPRODUCTO(B3:B15*C3:C15)/SUMA(B3:B15)    [Terminamos con Intro]
 
Cuarto método: Con tablas y SUMAPRODUCTO
 
Éste es el método más adecuado si prevemos que la lista de valores va a crecer (o disminuir). Partimos de la lista sin formato:
 
Accedemos a Insertar + Tabla y ponemos los datos siguientes:
 
Si abrimos la lista Cuadro de nombres comprobaremos que Excel ha creado un nombre llamado Tabla1.
 
La fórmula que vamos a usar es la misma que la del tercer método, pero adaptada al uso de las tablas. No escribiremos toda la fórmula; la construiremos así:
  1. Escribimos: =SUMAPRODUCTO(
  2. Con el ratón, seleccionamos B3:B15. Excel escribirá: =SUMAPRODUCTO(Tabla1[Nº personas]
  3. Añadimos (;) punto y coma: =SUMAPRODUCTO(Tabla1[Nº personas];
  4. De nuevo, con el ratón, seleccionamos C3:C15. El resultado será: =SUMAPRODUCTO(Tabla1[Nº personas];Tabla1[Edad]
  5. Cerramos paréntesis y añadimos la barra de la división: =SUMAPRODUCTO(Tabla1[Nº personas];Tabla1[Edad])/
  6. Escribimos: SUMA(
  7. Seleccionamos B3:B15 y cerramos el paréntesis. Acabamos con Intro.
  8. Resultado: =SUMAPRODUCTO(Tabla1[Nº personas];Tabla1[Edad])/SUMA(Tabla1[Nº personas])
Este método evita la necesidad de modificar la fórmula si añadimos o quitamos nuevas filas a la lista de datos. Para añadir nuevos datos al final, nos ponemos en la última fila y escribimos los valores. Si necesitamos insertar una fila entre la 7 y la 8, nos ponemos en la fila 8 (siempre en la inferior) y, con el botón derecho, abrimos el menú contextual. Eligiendo Insertar + Filas de la tabla arriba se insertará una fila en blanco donde podremos escribir los nuevos valores. Para eliminar una fila, por ejemplo, la 12, nos ponemos en una celda de la fila 12, abrimos el menú contextual y elegimos Eliminar + Filas de la tabla.
 
 
 
 

No hay comentarios:

Publicar un comentario