viernes, 20 de abril de 2012

Gráfico de líneas con fechas en el eje X a distancias proporcionales

Algunos terremotos importantes acaecidos en 2010 y 2011 han sido registrados en una hoja de cálculo (B2:D12) y, con ellos, queremos hacer el gráfico de líneas que se muestra a continuación:

En el eje horizontal del gráfico irán las fechas en las que se produjeron los terremotos, separadas por distancias proporcionales a las diferencias que hay entre ellas.

Necesitaremos usar las columnas M, N, P y Q para almacenar valores auxiliares.

Seleccionamos C2:D12, accedemos al grupo Gráficos de la pestaña Insertar y elegimos Línea + Línea con marcadores.

Eliminamos el título del gráfico y la leyenda (seleccionar + Supr). Hacemos doble clic en una de las líneas de división principales y ponemos:
  • Color de líneaLínea sólida / Color: Azul claro
  • Estilo de línea → Tipo de guión: Punto cuadrado
Hacemos clic con el botón derecho en el eje vertical y, en el menú emergente, seleccionamos Calibri + 9 ppp + Azul oscuro. Ponemos los mismos valores en el eje horizontal.

Hacemos doble clic en el eje vertical:
  • Opciones del eje → Mínima: Fija + 5 / Máxima: Fija + 9 / Marca de graduación principal: Ninguno
  • Número → Categoría: Número / Posiciones decimales: 2 / Usar separadores de miles: (poner marca)
  • Color de líneaLínea sólida / Color: Azul
Hacemos doble clic en el eje horizontal:
  • Opciones del eje → Eje del texto: (poner marca)
  • Color de líneaLínea sólida / Color: Azul
Hacemos doble clic en una línea del gráfico:
  • Opciones de marcadorIntegrado / Tipo: Círculo / Tamaño: 5
  • Relleno de marcadorRelleno sólido / Color: Verde claro
  • Color de línea de marcador → Línea sólida / Color: Verde oscuro
  • Color de líneaLínea sólida / Color: Rojo
  • Estilo de línea → Ancho: 1,75 pto
En la columna M, empezando en M15 (más adelante se entenderá la razón), escribimos todas la fechas comprendidas entre el 12/01/2010 (primer terremoto) y el 19/05/2011 (último terremoto).

En la columna N pondremos las magnitudes de los terremotos (empezando en N15).

En N15:
=BUSCARV(M15;$C$3:$D$12;2;FALSO)

Extendemos la fórmula hasta la fila 507, que corresponde a la fecha del terremoto de Kütahya (Turquía) ocurrido el 19/05/2011.

El siguiente paso consiste en sustituir la tabla de valores C2:D12 por M2:N507.

Con el gráfico seleccionado, accedemos a Herramientas de gráficos + Diseño + Seleccionar datos y cambiamos el valor del apartado Rango de datos del gráfico:
 
 
El gráfico habrá quedado así:

Al dejar en blanco las celdas del rango M3:N14, hemos conseguido que el marcador de la izquierda quede separado del eje vertical.

Ahora, hay que hacer una nueva modificación en el rango de datos del gráfico, pero antes es necesario crear dos nuevas columnas.

En P15:
=SI(ESNUMERO(N15);M15;"")

En Q15:
=N15

Seleccionamos P15:Q15 y extendemos ambas fórmulas hasta la fila 507. En la columna P sólo aparecen las fechas de los terremotos. Cuando en una fecha no hay terremoto, la celda está en blanco.

De nuevo, con el gráfico seleccionado, accedemos a Herramientas de gráficos + Diseño + Seleccionar datos y cambiamos el valor del apartado Rango de datos del gráfico:

Éste será el nuevo aspecto del gráfico:

Hacemos doble clic en el eje horizontal:
  • Alineación → Dirección del texto: Girar todo el texto 270º
  • Opciones del eje → Marca de graduación principal: Ninguno
Con el gráfico seleccionado, accedemos a Herramientas de gráficos + Presentación + Análisis + Barra de error + Más opciones de las barras de error.
  • Barras de error verticales → Dirección: Menos / Cuantía de error: Porcentaje + 100%
  • Color de líneaLínea sólida / Color: Azul claro
  • Estilo de línea → Tipo de guión: Punto cuadrado
Hacemos doble clic en el Área del gráfico:
  • Color del bordeLínea sólida / Color: Azul
  • Estilo de bordeEsquinas redondeadas
Ponemos un rótulo en el eje vertical accediendo a Herramientas de gráficos + Presentación + Rótulos del eje + Título del eje vertical primario + Título girado; escribimos: Grados Richter y, con el botón secundario, ponemos letra Calibri + Normal + 10 ppp + Azul claro.


 
 
 

No hay comentarios:

Publicar un comentario